Ticket #128 (closed defect: fixed)

Opened 8 years ago

Last modified 8 years ago

Vidalia process already running...

Reported by: tuleggi Owned by: developer
Priority: critical Milestone: Vidalia 0.0.8
Component: Vidalia Version: 0.0.6
Keywords: vidalia error process Cc:

Description

I have check the ticked already open and I have exactely this same problem with Vidalia 0.0.7 with XP sp1:

I cannot start Vidalia, it shows that another Vidalia process is already running and that the Vidalia process will now exit. The task manager doesn't show any other Vidalia process. Reinstallation did not help. Even the version change to 0.0.7 was not helpful. Until yesterday it worked fine.

I have Windows XP running

Regards

Change History

Changed 8 years ago by edmanm

  • milestone Vidalia 0.0.8 deleted

A couple people have mentioned this but no one has provided any details.

You said that until yesterday it worked fine. Did Vidalia crash at some point? Or did you close Vidalia normally and then the next time you went to run it, Vidalia would not start?

One person said restarting their Windows did the trick. If nothing else, you can also delete vidalia.pid, located in %APPDATA%\Vidalia\vidalia.pid and then start Vidalia.

Changed 8 years ago by anogeorgeo

I have exactely this same problem with Vidalia 0.0.7 with XP sp1:

SP1 might be the culprit in your case, I use XP Home SP2 and I have not experienced this bug with v.0.0.7. Try updating to SP2 and see if this fixes the problem, SP2 fixes quite a few bugs found in SP1.

I experienced this bug with v.0.0.6 (and previous releases), when I would use Task Man to kill Vidalia I couldn't restart Vidalia until I deleted vidalia.pid or restarted my XP.

Anogeorgeo

This bug was fixed in v.0.0.7 (at least for SP2), edmanm mentioned it was an issue with Qt framework.

Changed 8 years ago by anonymous

I am having the same problem also. Vidalia worked perfectly for a few days, then all of a sudden started having this error whenever I start it up. There is no sign of of vidalia in the Task Manager, and I am using XP SP2.

Changed 8 years ago by anogeorgeo

I am having the same problem also. 

What version of Vidalia are you using?

To test this bug do a hard-kill of Vidalia.exe using Task Man (or pskill.exe, process.exe, etc). Then re-start Vidalia and you will get the error message on pre-v.0.0.7 Vidalia releases.

The bug is due to the file "vidalia.pid" not being deleted after a hard-kill or crash of Vidalia. If you get this error message you can manually delete the file "vidalia.pid" from %SystemRoot?%\Documents and Settings\Owner\Application Data\Vidalia\ and Vidalia will run fine. Alternativly, you can re-start your computer (without deleteing vidalia.pid) and Vidalia will run fine.

I have tested v.0.0.7 with the above hard-kill methods and it re-starts fine without end-users deleteing vidalia.pid or re-starting their computer.

I can not reproduce this bug in v.0.0.7 no matter what I try. This was not the case with pre-v.0.0.7 in which I found this bug when I did a hard-kill or Vidalia crashed on it's own.

Anogeorgeo

Changed 8 years ago by anogeorgeo

I forgot to mention that I use XP Home SP2.

Anogeorgeo

Changed 8 years ago by anonymous

I am running v0.0.7. I can't kill Vidalia using Task Manager, as its not showing up as running in Task Manager. As far as I can recall Vidalia has never crashed, and I can't find a vidalia.pid on my pc at all to delete, which would to me suggest there is something to do with othe software on my pc that must be causing it. I'll try another fresh install and see if that helps

Changed 8 years ago by Magus

i'm also having this problem on two of my pc's. The software they run is completely different. Vidalia started giving me that error msg yesterday on my main pc then this morning on my second.

I've been able to run vidalia by running it as different user (using different credentials).

After opening up the profile in question i noticed that it did have vidalia.pid. Deleting this file fixed the problem. Thx!

Changed 8 years ago by anonymous

I'm SOMETIMES having this problem on XP pro SP2 and at system startup! I get the error messege once in about every 10 startups, but that's quite random, and no matter what I do I can't get vidalia to run. I'll update as I collect more details.

Changed 8 years ago by mrw@…

I have the problem in Windows 2000, SP4 (all current updates installed). v0.0.7 Vidalia. There is no V process (that I can see) in Task Manager. It seems to happen about 1/3 the time, doesn't seem to matter whether there is a clean or a dirty shut-down. The deleting vidalia.pid method described above lets me finally get vidalia started.

Changed 8 years ago by anonymous

Just installed tor/vidalia/privoxy package, ran fine til machine (cleanly) shutdown, next bootup I encountered the same problem described above. Win2K SP4. Deleted vidalia.pid, now works.

Changed 8 years ago by edmanm

  • milestone set to Vidalia 0.1.0

Changed 8 years ago by advspot@…

I am running Mac 10.4.7 with the latest stable Vidalia and Tor. After about two days of configuring Vidalia and Tor to work with Mac Standard User mode (had to resave torrc file as work around), now when I try to start Vidalia I get the error that Vidalia is already running. No instance of Vidalia is running on an user of the Mac or in the Activity Monitor. I have performed a clean reinstall with no success. However, it does work in the Admin user instance.

Any suggestions here?

Changed 8 years ago by advspot@…

Strike that ... my issue has been resolved. Vidalia was loaded in as a startup item by mistake and that was causing the issue. When I pulled it out of startup it worked again.

Changed 8 years ago by edmanm

  • status changed from new to closed
  • resolution set to fixed
  • milestone changed from Vidalia 0.1.0 to Vidalia 0.0.8

Fixed in Revision 1244 and will be in 0.0.8. Reopen this ticket if you still have trouble.

Note: See TracTickets for help on using tickets.